v1.6

By , September 27, 2020 18:27

This is a first major version since 2011. Mostly a bugfix release, no new features are added, but there are many internal changes.

Added compatibility with PHP 7.4. Minimal required version is v5.4.

jQuery was updated to v3.x branch.
Front-end html code now uses flexbox in most cases and SVG images as well.
That’s why support of Internet Explorer 8 was removed, but if you really need you can enable old ie8 theme (see readme.txt in ie8.zip in MTT bundle).
Support of Internet Explorer 11 and ie8 theme will be removed in the next major version.

New version uses translation files in json format. Old language files in php format can be converted to the new format in the settings. Download all languages you use and copy them to ‘content/lang’ folder. Translation maker is not updated yet.

Directory structure was changed. Added new folders: ‘content’ and ‘includes’. ‘themes’ directory was moved to ‘content’. jQuery and other internal files moved to ‘includes’ folder. Translation files are located in ‘lang’ directory in ‘content’ folder. ‘tmp’ and ‘db’ directories were not changed.

To upgrade installed version to this one just upload the contents of bundle excluding folder ‘db’. If you have translations go to settings and convert it. After upgrading you may delete ‘themes’, ‘lang’, ‘jquery’ folders in MTT root.

Download v1.6

Update 2020-10-03
v1.6.1 is published.

Update 2020-10-14
v1.6.2 is published.

All the changes you can find in changelog.

Based on Panorama Theme by Themocracy